Installer ModSecurity sur des serveurs cPanel

Niveau d'expertise: Medium 

ModSecurity est un module Apache qui permet la détection d’intrusions et la protection des applications Web, notamment contre les attaques connues et inconnues, telles que les attaques de type « injection SQL » ou de type XSS, les attaques par traversée de chemin, etc.

Pour installer ModSecurity sur un serveur cPanel, suivez les étapes suivantes :

  1. Suivez les étapes présentées dans l’article « Compiler Apache et PHP à partir de WHM ».
  2. Sur la page « Short Options List » qui sert à sélectionner des modules, cochez la case adjacente à « Mod Security ».
  3. Effectuez la recompilation d’Apache (en suivant l’article « Compiler Apache et PHP à partir de WHM »).

Veuillez consulter les captures d’écran suivantes.

mod_security.png

mod_security2.png

Vous avez d’autres questions ? Envoyer une demande

0 Commentaires

Cet article n'accepte pas de commentaires.
Réalisé par Zendesk